Template talk:Languages/Lang

From translatewiki.net
Jump to navigation Jump to search

Template Installation Question

I've made a wiki for my company's use on an intranet. We now have the need for translating articles on a page-by-page basis into German and this template is the perfect implementation. I have examined everything on Mediawiki.org and Meta.wiki, but I haven't had any help with solving what I'm sure is a simple problem. If anyone here has any advice, I'd be happy to hear it.

The problem, of course, is that the other language translations aren't showing up. I have subpages enabled with $wgNamespacesWithSubpages[NS_MAIN] = true;. Parser Functions 1.1.1 is installed, which is what Mediawiki is using. Mediawiki version 1.12.

Creating Sandbox and Sandbox/de and adding {{Languages}} to both pages produces a language bar with a link to the English page (accurate in both cases; English page is black text, German page is a link to the English page) but the German page is not detected and displayed in the language bar. The German page has the standard subpage-link below the article name. I have both Languages and Languages/Lang defined as Mediawiki.org does, so German is a registered language. I'm at my wits end -- Any advice? -Alex.eisenhart 18:07, 19 August 2008 (UTC)

Nevermind. =) If anyone gets here with a similar problem, ensure that ParserFunctions is included before most other extensions in LocalSettings.php. -Alex.eisenhart 19:57, 19 August 2008 (UTC)
There are no threads on this page yet.