[[MediaWiki:Group-autopatrolled/en]] & [[MediaWiki:Group-autopatrolled-member/en]]
Shouldn't these two messages rather be "Autopatrolled users" resp. "autopatrolled user"? The active form makes no sense to me as you cannot actively patrol with that right. Such a change would also be needed to stay in consistency with other "passive" rights like e. g. MediaWiki:Group-confirmed/en/MediaWiki:Group-confirmed-member/en and MediaWiki:Group-autoconfirmed/en/MediaWiki:Group-autoconfirmed-member/en resp. MediaWiki:Group-autoreview/en/MediaWiki:Group-autoreview/en.
The historical reason of this name is that the user is able to "self-patrol" their own edits. Originally, that wasn't automatic, you still had to flick "patrol" or select a checkbox in preferences. The secondary benefit is that we already have the term "patroller" (with its translations) and in many languages "auto-" is a known prefix, so "autopatroller" is potentially easier to translate.
I wouldn't change this without some more opinions, as I don't see a compelling reason to.