Jump to content

Accepting translations

Accepting translations

It is not possible to accept newly created translations via Special:Translate/!recent. It is only possible for changes on existing translations. In case you go directly to the message group you get the error "Accepting not possible ... Message was not found". This started about a week ago.

[[kgh]] (talk)17:08, 1 April 2012
Edited by author.
Last edit: 16:14, 4 April 2012

I have the same problem at mediawikiwiki. for example, I can’t accept my own created translation wikipedia:mw:Help:Extension:Translate/de, and I thought, it might be, that it’s just because I created these messages before getting the editor right. Can you accept this message, can you try that, please? I’m getting „Diese Version konnte nicht markiert werden. Zugriff verweigert.“ So I decided not to create more translations, if I’m not able to mark them as reviewed. Or is that another problem?

PS: I tried the same with English preferences: Now I’m getting "Unable to review this revision. Permission denied." Don’t know, if that’s the same or another mistake.

Geitost diskusjon20:14, 1 April 2012

You are never able to review your own translations. The error message tells though that there is another issue here too.

Nike (talk)07:56, 2 April 2012

I believe Geitosts error report has nothing to do with the error I reported. I am writing about messages created by other users. Since I cannot accept my translations I would not be able to press the button and receive an error message as reported in my thread.

[[kgh]] (talk)08:07, 2 April 2012

Ok, then it’s another thing. Are you able to review the linked translation or aren’t you? I’d like to know, where this mistake is. It means that I even can’t autoreview my own edits, then I can give up the editor right again, because it’s useless.

Geitost diskusjon11:27, 2 April 2012

I think you are talking about flagged revisions reviewing, aren't you?

Nike (talk)22:39, 3 April 2012

Yes, it’s also marking something as reviewed, so I thought that it maybe would be the same mistake. I tried a bit more. I can only mark something, when the first unreviewed version is after March, 28, when I have been given the editor right. So I can’t mark any of the versions I created myself, they all remain unreviewed.

And I can’t mark the versions of other people which I was seeing on the page, where I have been lead from my watch list saying there was something to review. Everything was ok with these old versions, but I just couldn’t mark anything of it, because the revisions were older, and noone is marking these old versions since decembre. I had no other chance than just taking it from my watch list for not seeing that every time and being the only watcher of the page (so now there’s no watcher anymore for it).

Is this a new thing with reviewing? I haven’t noticed this in the last 4 years of reviewing on de-WP and I reviewed many old redirects there which were older than March 2008, when flagged revisions were started there, so there this is possible and there wouldn’t be any sense not to be able to mark them, because then noone could mark these old redirects as reviewed (and noone would have been able to mark old articles from 2001 up to 2008 either, which means, thas the flagged revisions would have been completely useless), just because noone had the editor right before March 2008. Is there any sense in that or is it a bug?

I just was or am not sure, if it perhaps just might be another component of the same bug with marking versions in any way. On the other hand, "Message was not found" and "Permission denied" sounds like being to different things (maybe also two different bugs?).

Geitost diskusjon23:29, 3 April 2012

Yes they are different things and reporting flagged revs in this thread confused me hella lot. There is known issue about reviewing pages translated with Translate extensions.

Nike (talk)07:08, 4 April 2012

Ok, thanks, I didn’t knew that. That’s a pity. A bot marking pages as unreviewed, and no version after that can be seen anymore at once, if someone isn’t logged in. :-( Don’t know, what to do with this.

Geitost diskusjon16:18, 4 April 2012
Edited by another user.
Last edit: 10:56, 6 April 2012

The bug is bugzilla:33385 and the fix should be deployed in few weeks.

Nike (talk)08:36, 6 April 2012

When will the fix go live? It's still not possible at MediaWikiWiki to accept these versions mentioned also in Bug 35135 which is marked as just a duplicate to Bug 33385. I still get the messages mentioned above already. I thought the new MediaWiki version is live on all foundation wikis now. Has it not been deployed with this new version?

Geitost diskusjon22:04, 27 April 2012

Please, we are talking about multiple issues in this thread, you have to be very precise what you are talking about. What is the exact error message and what is the exact action you are trying to perform.

Nike (talk)13:14, 28 April 2012

If I try to review for example this revision mentioned in Bug 35135, I still get

  • "Unable to review this revision.
  • Permission denied."

If I try to review it and the page is still loading, then I'm getting another Special page https://www.mediawiki.org/w/index.php?title=Special:RevisionReview&action=submit saying

  • "Permissions errors
    • You do not have permission to <action-badaccess-group0>, for the following reason:
    • You are not allowed to execute the action you have requested."

I don't know what means action-badaccess-group0 here, but I'm in the editor group since March, so why isn't it possible to review many help pages there? The bug has been marked as duplicate of Bug 33385, there it has been fixed by Aaron Schulz on 2012-03-08 19:43:07 UTC in r113389 as he wrote there. So I don't understand, why it is still impossible to mark this revision of Bug 35135. That also applies on many other help pages that I'm also not able to mark and I don't think any other person can do that. For example: wikipedia:mw:Help:Extension:Translate/de: just the same as above, and many other help pages that can be edited via the translation feature.

Or these 55 intermediate revisions, unreviewed since an edit of the Fuzzy Bot on 27 Decembre, same error message again. I looked at all the 55 revisions, there's everything ok with it, but it can't be marked. So I think, that IP users are still seeing this old English revision instead of the newest one. It's unreviewed since 124 days now, so I just put it off my watchlist saying there's something to review which just can't be reviewed. :-/ and there are other very old pending changes which can't be reviewed, see wikipedia:mw:Special:PendingChanges. That leads to the point that people aren't reviewing anymore, because they always just get this error message since many months. :-(

Geitost diskusjon11:16, 29 April 2012

Aaron has submitted a new fix proposal: https://gerrit.wikimedia.org/r/#change,6222 It will likely take two to four weeks until it is in production, unless it is expedited.

Nike (talk)10:09, 3 May 2012

Ok, hope it will work then. Thank you. :-)

Geitost diskusjon21:34, 10 May 2012

Does it work now?

Nike (talk)10:41, 29 May 2012

No, it doesn’t. I tried it right now again with both pages. Same message again. :-(

Geitost diskusjon19:24, 17 July 2012

@kgh: Maybe you need reviewer rights.

Michawiki (talk)12:04, 2 April 2012

Is the issue still there? Can you give link?

Nike (talk)22:38, 3 April 2012

Seems to work at the moment. Thank you for fixing it since this problem would otherwise make the system of accepting translations useless.

[[kgh]] (talk)09:16, 5 April 2012